10 de mar de 2009

Weblogic - Travamento ao clicar no Activate do Admin Console

Hoje foi um dia muito corrido no trabalho, trabalhei bastante e não deu tempo de implementar a API de persistência e nem trabalhar no módulo Struts. Começei a escrever um tópico sobre upload no struts 2 que devo terminar amanhã.

Vou então deixar uma dica rápida relativa ao weblogic 10.X. No admin console depois de clicar em Lock & Edit e editar as altarações que deseja e voltar em clicar em Activate o console trava, fica processando e nada acontece. É um erro que infelizmente vem ocorrendo com certa frequência no trabalho do dia a dia com weblogic. 
São 2 as principais e mais usuais causas deste tipo de problema: 

1) Quando o domínio do weblogic é distribuído em mais de um hardware e está configurado para conectar no nodemanager e este não está funcionando corretamente.

2) Quando alguma permissão no diretório de instalação do weblogic ou do domínio perderam a permissão de escrita ou direito de apagar arquivos, renomear etc... Isso é comum quando, por exemplo, em qualquer ambiente unix ou derivado é criado um usuário e um grupo para o weblogic como: weblogic:weblogic e alguém editou ou manipulou algum arquivo como root retirando a permissão do usuário. Isso faz com que o console tenha o mesmo comportamento de impossibilidade de ativar as alterações.

As situações acima são as que mais comumente causam o problema do aparente "travamento" ao clicar em Activate, na verdade não trava o console mas o activate nunca consegue completar. O chato desta situação é que o console não mostar nenhuma mensagem e também nada sai no log do Admin console informando o que está causando o problema, o que dificulta muito descobrir o que está acontecendo.
Fica esta dica e lembrete sobre o problema. 
[]s

Nenhum comentário: